Opel GT Forum banner

1 - 20 of 39 Posts

·
Registered
Joined
·
1,241 Posts
Discussion Starter #1
Eh everyone.I'm not good on electrical issues so got a local mechanic to install the Crane XR-3000 with the PS91 coil. He's having troubles fitting the unit on the distributor. He's asking if there are any pictures out there that can help. If anyone has this or any help at all please please please. Thank you very much.
 

·
Registered
Joined
·
1,241 Posts
Got a 440-3 in my 78 winnebago! Actually found a before & after picture in the OGTS catalogue. Not sure if the picture is the Crane xr 3000 or 700.Wonder if they're both the same fitment on the distributor? Note .With you that have done this & have the combo cam type rebuild did you change one of the springs in the distributor or leave it? thanks
 

·
Super Moderator
Joined
·
8,170 Posts
Note .With you that have done this & have the combo cam type rebuild did you change one of the springs in the distributor or leave it? thanks
Installed an Allison (later purchased by Crane) electronic conversion. The installation was spelled out fairly well in the instructions. You can 'fine tune' the optical pick up without installing the distributor, IIRC. With everything hooked up slowly rotate the distributor shaft by hand and note where it 'sparks'. The rotor should be pointing directly at an ignition terminal in the cap. I made a hole in a distributor cap so I could make sure it was 'dead on' A clear distributor cap would also work for this.

Rallybob has suggested replacing the 'loose' spring with another one with constant tension on it for the advance mechanism.

Harold

P.S. Make sure to mount the control box where it can get air and don't paint it. I can tell you from experience what will happen if you do. :D I didn't paint it, but I did have to replace it afterwards. :haha: Not my car, that and it was a looong time ago, that's why I can laugh.
 

·
Registered
Joined
·
1,241 Posts
Discussion Starter #12
Good point may have to rethink my placement. They're mounted now but not hooked up. I put the coil & Xr 3ooo on the flat ledge right in front of the driver just under the hood on the gt.hood clears but not by much.Do you think its to tight for circulation or ok . Not sure how much these things heat up & don't want to damage the paint on the hood either. The location looks nice!:confused:
 

·
Super Moderator
Joined
·
8,170 Posts
I put the coil & Xr 3ooo on the flat ledge right in front of the driver just under the hood on the gt.hood clears but not by much.Do you think its to tight for circulation or ok . Not sure how much these things heat up & don't want to damage the paint on the hood either. The location looks nice!:confused:
Roy 'Ooooner' Bell may have pictures of his posted, if not he should. IIRC, his is mounted on the radiator core support near the brake booster brace.

Harold
 

·
Registered
Joined
·
1,241 Posts
Discussion Starter #15
Well all hooked up & working. Will have pictures soon. Now I just need winter to leave to really Dial things in . Had to order the Rotor without a resister as local suppliers couldn't. Looks real nice getting the old coil can & resister out of there.
 

·
Registered
Joined
·
1,241 Posts
Discussion Starter #17
Pictures for set up of xr 3000 crane ignition & ps91 coil.

Hope this goes in. These are some of the pictures from a neighbour Mechanic that helped me set up the distributor & hook everything up. With many thanks to Rally Bob & others for lots of info to get this together. All is hooked up & running fine but not tested as yet because of winter up here in the great white north.There's also a picture of the setup in OGTS catalogue which may be different. Runs right now with the original rotor with a resistor . The proper one is on order without the resistor. Couldn't order local so ordered it from CB performance # 2004 . Used my Chromed coil bracket for the fuel filter.Same size & looks good. Good luck
 

Attachments

·
Super Moderator
Joined
·
8,170 Posts
I didn't use the second brace that you did in the install I did years ago. But then again I don't recall the 'mickey mouse' bracket extending out anywhere near as far as yours does. Installation looks good to me. :yup:

Harold
 

·
Super Moderator
Joined
·
3,133 Posts
Roy 'Ooooner' Bell may have pictures of his posted, if not he should. IIRC, his is mounted on the radiator core support near the brake booster brace.

Harold
Mine was mounted on the radiator support but I had to move it due to the heat from the radiator and, I guess, the engine. It would run great until it got real hot during the summer months and would start missing. At one point, I had a "vapor lock" which had nothing to do with the Crane Ignition. After going through everything and scratching a bald spot on my head, I asked around and came to the conclusion that heat was bothering the ignition "box". I moved the "box" to the fender area and put some spacers underneath so air would circulate around it to help keep it cool. I haven't had a problem with it since and runs great!

Hope this helps.
 
1 - 20 of 39 Posts
Top