Opel GT Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I ran a quick search on this and didn't find anything. I've got a '69 GT with a rebuilt 32/36 Weber carb (rebuild was a couple years ago). In the last year the fast idle has not been working. It has an electric choke and from what I can tell it is working fine. When I start the car after it has been sitting overnight I used to be able to press/depress the gas pedal to the floor to set the fast idle and then start the car with a crank or two. When warm I could tap the gas and the idle would drop back down. Now I have to crank the car several times while holding on the gas pedal slightly. After it starts I have to hold my foot on the gas pedal to keep it running till it warms up. Possible flooded engine?

This is the only drivability problem that I have with the car. I ran a couple oil analysis's on the oil after 6 months/ 500 miles and the report said it had dangerously high levels of gas mixed in the oil! The flashpoint was getting too low. When I check the oil on the dipstick it smells like gas.

I noticed a strange thing the other day and I'm not sure if it's normal. I was looking over the engine and I heard slow drip sound coming from inside the carb. I also noticed that when I stopped the car after a drive the fuel filter didn't have any air in it - filled completely with gas. Now it was 1/4 air. Could that remaining gas be draining into the intake manifold & down into the engine?

I've talked to several opelers about this but haven't gotten any solid answers. I'm hoping this is an easy fix with the carb or something but unfortunately I'm not too savvy when it comes to carbs. I would appreciate the forum's help on this.

Thanks
 

· 1000 Post Club
Joined
·
4,128 Posts
Gas in Oil

Pasted this from your previous thread.

It sounds like a bad fuel pump. If the diaphram is ripped, you will dump fuel into the oil. Not good for bearings and such. They are inexpensive, you can get them locally or from OGTS. I recommend OGTS because you know you are getting a new one, not one that has been sitting on a shelf for years. Don't forget to save the spacer

Someone else will have to help you with the carb issue.

HTH

Jeff
 

· Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
I'm hoping it is a fuel pump, but I thought that if the symptom of a bad fuel pump diaphram was that the oil would leak out of the fuel pump since it is lower than where the oil is. If the diaphram was bad, for gas to get into the oil wouldn't the gas have to run up to get into the engine?

BTW - There is oil on the fuel pump but unfortunately that isn't saying much b/c there is oil all over the engine!

PS - Harold, this is Steve. As you can tell I haven't installed your fuel pump yet. Just want to make sure this will fix the problem. Maybe we could take a look at the float settings at the meet?
 

· Super Moderator
Joined
·
8,421 Posts
Who rebuilt your Weber some knowledgeable Opel person I hope. :rolleyes:

I almost always double and triple check the float setting. My money is on the fuel pump being bad. Sometimes when they go bad the gas leaks externally sometimes internally. Either bad for the environment or bad for the car. Of course if it leaks externally and causes a fire it is both.

Replace your pump and if it doesn't cure your problem I'll bring what we need to check the float level.

Harold
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top