Opel GT Forum banner
1 - 2 of 2 Posts

· Opel fan
Joined
·
357 Posts
stereo

For the radio, I'd check to see if I had power to them at the appropriate times. Constant power for the memory and switched with the ignition for the radio. Check your power sources and grounds, make sure they are good. Did you accidently ground your speaker wires while putting the molding around the doors, or the installing the rear deck etc.. Sometimes it takes a while when a wire gets mashed to ground out. Is the cd player separate from the rest of the radio or an in dash cd player? Am I understanding you correctly that the radio/cd only works when the headlights are on, or is it that it only makes sound when the head lights are on? Was it working fine with the headlights off before and suddenly changed to working only when the headlights are on. Anything else weird going on with the electrical system? Blinkers etc..
 

· Opel fan
Joined
·
357 Posts
Sounding really good might have been cranked up really loud? Check the fuse to the radio, do that first if it is easy to get to. You might have blew a fuse on the fuse box where the power supply was coming from. Do you have a test light to check with? If you are getting power to the red and yellow wires past the inline fuses of the wires coming out of the radio, that means the power should be getting to the radio. If then it's still not working, I'd check your speaker wires to make sure they are not grounded to the frame anywhere.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top