Opel GT Forum banner
1 - 3 of 3 Posts

·
1000 Post Club
Joined
·
1,247 Posts
Discussion Starter · #1 ·
Well as some may know, only a couple of months ago, my Opel started for the first time. Well I've started it probably 15-20 total times now, only running for a max. of 1 or 2 minutes. Well yesterday, I got the clutch all working, and I had it up on stands to see if it'd work. Well it did, awesome too. Well after the engine was running for like maybe 5-7 minutes, it started smoking (maybe steam) quite a bit. It wasnt thick, but enough to make me worry. I shut the engine off and waited for the smoke/steam to clear and looked for wetness. Well all over a certain part of the Intake was really wet, and the carberator was kind of wet also. I know my valve cover gasket has a slight leak, but I don't think its leaking THAT bad. Well my first though since the intake and carb were wet, was Gas. But it didn't really smell like gas at all. I remember seeing coolent a while ago, but that dont seem to be leaking anymore, and it didnt smell like coolent. Does anyone have any idea's on what to check or what kind of gasket to buy? I need to know quick so I can get it ordered, because I only have a little over 3 weeks to get my car done!

To me, my guess is either the intake/exhaust manifold, or maybe some gasket in the carborator.

Thanks in Advance, Jon
 

·
1000 Post Club
Joined
·
1,247 Posts
Discussion Starter · #3 ·
well when I FIRST started it.. there was a hose, or something leaking coolent, but like I said before, it did not smell like coolent,even though that would make me very happy...much easier fix.
 
1 - 3 of 3 Posts
Top