Opel GT Forum banner

1 - 4 of 4 Posts

·
Opeler
Joined
·
3 Posts
Discussion Starter · #1 ·
Once again I need to dip into the great knowledge of the opel forum.

My GT has developed a problem at warm idle. It Won't. As soon as the RPMs drop the motor dies. It has also started popping though the exhaust when RPMs start down. The car will start right back up with my foot on gas to hold the RPMs up. When the motor is cold and choke is engaged it runs fine. With my foot on the gas it chugs a little, but seems to run ok. The car has just developed this problem. It was running fine until the other day when this started

It has a Weber carb that has been on the car for about 4 years and car has the stock motor in it.

I've checked for vacuum leaks and hit the carb with cleaner.

Any Ideas of where I should start next.

Any help would be great.

Thanks
 

·
Detritus Maximus
Joined
·
2,790 Posts
You are either flooding (dirt in system or float sticking 'down' or needle and seat sticking open), which is countered by having your foot on the gas, thereby raising the rpm and masking the flooding.
Or you are not getting enough fuel at idle. This could be blockage in the carb passages related to the idle circuit or the float is sticking up or needle and seat are sticking closed.
Inspect, clean, and adjust these things.
 

·
Opeler
Joined
·
3 Posts
Discussion Starter · #3 ·
Running Good Again

It has taken about week to even look at the car again

I check the my idle jet and it was clogged with something and would not let any air blow threw. I cleaned it up and now the car is running fine

Thank you for your help,
 

·
Detritus Maximus
Joined
·
2,790 Posts
Anytime!:cool:
 
1 - 4 of 4 Posts
Top