Opel GT Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
I am starting to restore a '71' GT. One of the projects is that of redoing the whole brake system. Every time I tighten down the front calipers with the two main bolts it locks up the rotor. What am I doing wrong, or what am I missing? Advice appreciated.
 

·
Detritus Maximus
Joined
·
3,691 Posts
Are you doing this with the pads installed? If so, the caliper pistons may be sticking out too far. Or seized.

Or- any chance you have the 69-74 calipers and 75 rotors? The 75 rotors are larger in diameter.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
The pads are installed but I can see light between the pads and rotor. It is a set of 72 calipers on a 71 rotor. I even tried adding a spacer to the bolts but as soon as it starts getting tight, it locks up the rotor.
 

·
Detritus Maximus
Joined
·
3,691 Posts
If you have the pads in, I assume you also have the pad retaining hardware (Pins and spring plate) in also? Look to see if the perimeter of the rotor is hitting the plate or pins.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
Hey, thanks for the suggestions. Finally found the problem. the pad on one side was thicker on the inside edge. So even though I could see space between it and the rotor at the outside edge, it was clamping down inside. Going to have to return those. Thanks for the suggestions.:rolleyes:
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top